galtoolslib not compiling
Page 1 of 1

Author:  jcooper2 [ Fri May 10, 2024 11:20 am ]
Post subject:  galtoolslib not compiling

Hi, I am having trouble getting the install script to run past the compiling of galtoolslib on a Mac running Sonoma v13.5.2. I have gcc and gfortran up to date (through homebrew and the xcode command tools - i've tried pointing the script to both) and the compiler stops at galtoolslib. The log files show an error for libskymap.dylib, is there an issue with what files need to be in my path?

Thanks for any help!

Galtoolslib build log.png
Galtoolslib build log.png [ 134.33 KiB | Viewed 293 times ]

Author:  tporter [ Tue May 14, 2024 8:36 pm ]
Post subject:  Re: galtoolslib not compiling

This is almost due to a mismatch in the C++ ABI between libstdc++ and libc++. Please try clang/clang++. I use MacPorts versions for these, and the build/install works.

Author:  jcooper2 [ Wed May 22, 2024 11:19 am ]
Post subject:  Re: galtoolslib not compiling

Thanks for replying, (and sorry i got back to you a bit late), but that seems to have worked, and GALPROP compiled successfully! Though I did have to use gfortran still, so it is a bit weird.

Thanks again!

Joseph Cooper
Oakland University

Page 1 of 1 All times are UTC - 8 hours [ DST ]
Powered by phpBB® Forum Software © phpBB Group