It is currently Sun Nov 28, 2021 5:07 pm

All times are UTC - 8 hours [ DST ]




Post new topic Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Mon Jul 29, 2013 6:40 pm 
Offline

Joined: Sun Jul 07, 2013 8:48 am
Posts: 8
Hi Galprop users,
I have installed everything (Cfitsio,CCFITS, gls, Healpix, clhep). I ran a make test
in all of them and they properly installed apparently!

I run: ./configure --with-cfitsio=/home/farinaldo/Documents/cfitsio --with-ccfits=/home/farinaldo/Documents/CCfits --with-healpix=/home/farinaldo/Documents/Healpix_3.10/src/cxx/generic_gcc --with-gsl=/home/farinaldo/Documents/gsl-1.16 --with-clhep=/home/farinaldo/Documents/2.1.3.1/CLHEP --prefix=/home/Documents/galprop-54.1.984 --with-galdef=/home/farinaldo/Documents/galprop-54.1.984/source/Galdefiles --with-fitsdata=/home/farinaldo/Documents/galprop-54.1.984/source/Fitfiles --datadir=/home/farinaldo/Documents/galprop-54.1.984/source/datfiles CXX=gcc F77=gfortran CXXFLAGS="-fopenmp" FFLAGS="-fopenmp"

It goes smoothly, but I when I run : make , then the error message always appears:

HealpixBaseExtended.cc:14:5: error: specializing member ‘T_Healpix_Base<int>::ring_above’ requires ‘template<>’ syntax
make[2]: *** [HealpixBaseExtended.o] Error 1
make[2]: Leaving directory `/home/farinaldo/Documents/galprop-54.1.984/source'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/farinaldo/Documents/galprop-54.1.984'
make: *** [all] Error 2

I have no idea what's going on. I tried different versions of Healpix and the problem persists. As I said above I run
make c-test and make cpp-test on Healpix and everything is ok.

Help please! I've been trying to install Galprop for over a week!
Thank you for your time.


Top
 Profile  
 
PostPosted: Mon Jul 29, 2013 11:40 pm 
Offline
Site Admin

Joined: Wed Oct 21, 2009 6:30 pm
Posts: 47
Location: Stanford U.
Healpix version 3.10 is not supported by Galprop v 54. Please compile with Healpix 2.20.

_________________
Andrey Vladimirov
http://galprop.stanford.edu/


Top
 Profile  
 
PostPosted: Tue Jul 30, 2013 10:45 am 
Offline

Joined: Sun Jul 07, 2013 8:48 am
Posts: 8
Ok. Thanks. I will try.


Top
 Profile  
 
PostPosted: Tue Jul 30, 2013 4:38 pm 
Offline

Joined: Sun Jul 07, 2013 8:48 am
Posts: 8
It worked.
Thank you very much.


Top
 Profile  
 
PostPosted: Thu Aug 08, 2013 9:41 am 
Offline

Joined: Sun Jul 07, 2013 8:48 am
Posts: 8
Yes. It was solved.
I just had to install the Healpix2.20 instead of a newer version of Healpix.

Thank you all.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC - 8 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group