It is currently Mon Dec 06, 2021 10:04 pm

All times are UTC - 8 hours [ DST ]




Post new topic Reply to topic  [ 9 posts ] 
Author Message
PostPosted: Thu Oct 21, 2010 11:27 am 
Offline

Joined: Mon Oct 04, 2010 9:34 am
Posts: 2
I've been doing 3D WebRuns with the default parameters, changing only the max_Z in nuclear abundances, and the FITS files generated seem to contain no values. Even the quick plots show no data. 2D, however, seems to be outputting data fine. I'm new to Galprop, so I've just been doing a few test runs with the already set parameters. I would appreciate some advice on the matter since there's every chance I'm doing something horribly wrong.
Thanks.


Top
 Profile  
 
PostPosted: Thu Oct 21, 2010 12:47 pm 
Offline
Site Admin

Joined: Wed Oct 21, 2009 6:30 pm
Posts: 47
Location: Stanford U.
For 3D runs, try setting parameter use_symmetry=0 (in the group Common Parameters).
We need to introduce a fix for this either in the code, or in the WebRun validation rules. I will follow up with more details on this soon.

_________________
Andrey Vladimirov
http://galprop.stanford.edu/


Top
 Profile  
 
PostPosted: Thu Oct 21, 2010 5:57 pm 
Offline

Joined: Mon Oct 04, 2010 9:34 am
Posts: 2
Great, that's sorted it out.
Thanks a lot.


Top
 Profile  
 
PostPosted: Fri Oct 22, 2010 12:03 am 
Offline

Joined: Wed May 17, 2006 7:02 am
Posts: 285
Location: MPE Garching
I added a warning about this parameter in the GALPROP Explanatory Supplement .
In fact now that computer resources have multiplied since GALPROP originated, the symmetry options are pretty much obsolete.

_________________
Andy Strong, MPE


Top
 Profile  
 
PostPosted: Sun Oct 24, 2010 10:30 am 
Offline

Joined: Wed May 17, 2006 2:35 pm
Posts: 19
Location: Santa Cruz, California
We don't use the symmetry option for calculations, but it's very possible that we have checks in the code if to use it, and then do something, etc. -- these should be cleaned out.

_________________
Dr. Troy A. Porter
Hansen Experimental Physics Laboratory
452 Lomita Mall
Stanford University
Stanford, CA 94305


Top
 Profile  
 
PostPosted: Sun Oct 24, 2010 10:37 am 
Offline

Joined: Wed May 17, 2006 7:02 am
Posts: 285
Location: MPE Garching
symmetry is only invoked iff use_symmetry>0

actually symmetry used to work fine ... and was well tested.
something happened somewhere since then, evidently.


I will make a test to find out what went awry.

It is not worth the effort to fix it probably, just avoid it.

_________________
Andy Strong, MPE


Top
 Profile  
 
PostPosted: Sun Oct 24, 2010 1:06 pm 
Offline
Site Admin

Joined: Wed Oct 21, 2009 6:30 pm
Posts: 47
Location: Stanford U.
It may be that the fits files with use_symmetry=0 are not empty, but the plotting program in WebRun cannot do interpolation to the Sun's location properly.

_________________
Andrey Vladimirov
http://galprop.stanford.edu/


Top
 Profile  
 
PostPosted: Sun Oct 24, 2010 11:35 pm 
Offline

Joined: Wed May 17, 2006 7:02 am
Posts: 285
Location: MPE Garching
now I'm confused: I thought use_symmetry=0 did solve the problem, according to what is written above.
and that use_symmetry = 1 was the problem.
so the problem is just the plotting ? then use_symmetry = 1 is perhaps OK (which is what I would expect) ?

_________________
Andy Strong, MPE


Top
 Profile  
 
PostPosted: Sat Oct 30, 2010 1:54 pm 
Offline
Site Admin

Joined: Wed Oct 21, 2009 6:30 pm
Posts: 47
Location: Stanford U.
Sorry, I said it the other way around. What you think is correct, use_symmetry=0 works fine.

_________________
Andrey Vladimirov
http://galprop.stanford.edu/


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

All times are UTC - 8 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group