GALPROP
https://galprop.stanford.edu/forum/

Exceeding resources for 3D model
https://galprop.stanford.edu/forum/viewtopic.php?f=20&t=94
Page 1 of 1

Author:  deil [ Sun Aug 29, 2010 6:15 am ]
Post subject:  Exceeding resources for 3D model

Hello,

my 3D GALPROP WebRun failed after running for a day:
http://galprop.stanford.edu/wrxiv/0353/ ... ist.tar.gz
Exit Status: failed (may have exceeded resources)

The end of the log file is:
Line #
2526 create_transport_arrays: ======== assigning momentum loss rate ========
2527 create_transport_arrays: ============== completed creation of transport arrays for Oxygen_16
2528 create_transport_arrays: Exit
2529 gen_secondary_source: Entry
2530 gen_secondary_source: Exit
2531 propagate_particles:
2532 Network iteration 1 species 21 Oxygen_16 (Z,A) = (8,16)
2533 propel: Entry
2534 propel: Generating alpha for 3D
2535 propel: timestep_mode=1


What parameters cause the excessive resource requirements?
What do I have to change to run a 3D model?

Thanks!
Christoph

Author:  tporter [ Sun Aug 29, 2010 11:33 pm ]
Post subject:  Re: Exceeding resources for 3D model

The 3D run is more memory expensive than a 2D run (obviously). You might try reducing the spacing of your x and y grid (say, make it 1 kpc x 1 kpc) for a 20 x 20 kpc galaxy. Each run is currently limited to a 16 GB max memory footprint and I can run a 20 x 20 kpc (1 kpc spacing) with a 10 kpc halo (0.1 kpc spacing) within this. Also, if you are running in healpix output mode, running with very high resolution maps (maybe order 8, certainly order 9) will exhaust the resources for your run. Try running with order 7 (~1/2 deg spacing), or less.

Page 1 of 1 All times are UTC - 8 hours [ DST ]
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/