GALPROP
https://galprop.stanford.edu/forum/

What GALPROP parameters to use for emission above 1 TeV?
https://galprop.stanford.edu/forum/viewtopic.php?f=20&t=93
Page 1 of 1

Author:  deil [ Sun Aug 29, 2010 6:09 am ]
Post subject:  What GALPROP parameters to use for emission above 1 TeV?

Hi,

I am trying to model the gamma-ray emission up to 100 TeV.

Here is my first attempt:
http://galprop.stanford.edu/wrxiv/0353/ ... uo2.tar.gz

As the WebRun Quick Plot (attached) shows, the inverse Compton spectrum is non-smooth above 1 TeV.

Why is that?
What parameters do I have to change to get a smooth spectrum?

Are my other parameters reasonable, or should I change some to get a good estimate of the emission at very high energies?
What parameters would correspond to a model where the high-energy emission is as bright as possible without violating any strong constraints, such as Fermi measurements?
Besides the spectrum I am also interested in the scale height in GLAT of the emission, i.e. in the region abs(GLAT) < 3.

Any help and pointers are much appreciated!

Christoph

Attachments:
gamma_54_03530002_1282898632.png
gamma_54_03530002_1282898632.png [ 12.5 KiB | Viewed 6483 times ]

Author:  avladim [ Tue Aug 31, 2010 8:55 pm ]
Post subject:  Re: What GALPROP parameters to use for emission above 1 TeV?

Christoph,

I made a similar run, setting the electron and photon energy grids to your values (Ekin_min=1e1, Ekin_max=1e8; E_gamma_min=1e4, E_gamma_max=1e8; long_min=0; long_max=360; lat_min=-5; lat_max=+5). I did not use anisotropic IC, just to save time. Results:
1) for E_gamma_factor=1.5 (like in your run) I get the same jagged spectrum of IC.
2) for E_gamma_factor=1.3 (just to make it smaller), IC came out with a smooth spectrum.
3) for E_gamma_factor=1.19 (a test), the IC spectrum is jagged again.

I think it is related to the fact that Ekin_factor=1.3 in these runs, and there must be some interpolation problem in GALPROP. Anyway, setting E_gamma_factor=Ekin_factor seems to work for now, and the other cases reveal a problem.

Please try re-running your configuration with a different Ekin_factor (the Import button in the Download Results section will copy all the parameters into a new form), and if you find the same, would you kindly file a bug report via http://galprop.stanford.edu/bugs/ ? I am asking you to do this instead of doing it myself because it will set a good example if users outside the GALPROP team participate in bug reporting :)

Andrey

Author:  deil [ Wed Sep 01, 2010 1:32 am ]
Post subject:  Re: What GALPROP parameters to use for emission above 1 TeV?

I ran using the parameters you suggested, got the same results and filed a bug report:
http://galprop.stanford.edu/bugs/show_bug.cgi?id=6

My other questions stand: if someone has suggestions about good GALPROP parameters to model 1 -- 100 TeV emission, please don't hold back. Preferably I would use a published model, so if someone can refer me to a paper that would be great!

Page 1 of 1 All times are UTC - 8 hours [ DST ]
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/